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"Streamlining cross-company 
processes is the next great 
frontier...where this decade’s 
productivity wars will be fought." 

–Michael Hammer, 
"The Superefficient 
Company," The Harvard 
Business Review, 
September 2001
Chapter 1

Introduction To
Process Modeling

Modeling and Simulation Basics
This chapter explains the process for creating a basic process model, 
running the simulation, and viewing the output reports and graphs. It is 
designed as a hands-on exercise that can be followed using the software. It 
contains the step-by-step instructions to help you learn how to:

• Define the Process Flow

• Define Resource Assignments

• Enter Process Information

• Simulate your ProcessModel

• View the Output Reports

In addition, this chapter answers the following questions:

1. What is a Process Model?

2. What are the main components of the ProcessModel Modeling 
Environment?

3. What are the basic objects used in a Process Model?

4. What are connections?
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Introduction To Process Modeling
Key Concepts
This section presents the concepts necessary to successfully complete 
the process for creating a process model, running the simulation, and 
viewing the output reports and graphs. Specifically you need to 
understand:

• Process Models

• The Modeling Environment
° Layout Window
° Toolbox
° Simulation Menu
° Properties Dialog
° Gallery
° Shape Palette

• Objects
° Entities
° Activities
° Resources

• Connections
° Entity Arrivals
° Entity Routings
° Resource Assignments

Process Models
A process model is a flow diagram with associated operational 
information for simulating a process. A process flow diagram consists 
of objects (the graphic shapes in the flowchart) and connections (the 
lines connecting the graphic shapes). Objects represent the elements 
of the process while connections depict element relationships. A 
Properties Dialog displays the operational information for each object 
and connection.

“As the (Six Sigma) industry 
moves forward, simulation tools 
will be greatly beneficial in 
processes that are more difficult to 
pin down. Processes that are 
integrated across a variety of 
departments or business units are 
a great example...These complex 
environments almost demand 
process simulation.” 

–Eric Edwin
Vice President
SBTI
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Key Concepts
The Modeling Environment

Layout Window
The layout window for drawing the flow diagram is a scrollable 
drawing area that is divided into pages. Pages correspond to what you 
would see if the diagram were printed. You may start the diagram 
anywhere on the layout although it is usually best to start in the upper 
left corner. The diagram can be easily moved later if needed.

Toolbox
The Toolbox is the column of buttons displayed on the left side of the 
layout window. The primary buttons in the toolbox are the pointer 
button used to select objects, the shape button used to place new 
shapes on the layout, and the line button used to connect the shapes. 
The other buttons are for adding text, zooming and changing the line 
style.

Simulation Menu
The Simulation menu allows you to run the simulation, define 
scenarios or experiments, run experiments and set simulation options.
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Introduction To Process Modeling
Properties Dialog
The Properties Dialog allows you to define simulation information for 
each object and connection in the model. 

Gallery
The Gallery is a formatting command center. From the Gallery you 
can place shapes for your model, change color, font, line style, line 
ends and shadowing. The Gallery is positioned on the right hand of 
the screen for easy access.

Shape Palette
A shape palette allows you to select each shape used to represent each 
object in the model. The default shape palette is called General and 
contains shapes that are commonly used for process diagramming. 
Other palettes and shapes may also be used if desired.

Objects
Objects are the graphic shapes in the flowchart. They include:

Entities
The items or people being processed, e.g., products, documents, 
customers, etc.

Activities
The tasks performed on entities such as assembly, document approval 
or customer checkout. 

Resources
The agents used to perform activities and move entities such as 
service personnel, operators or equipment.

“As Six Sigma is deployed 
throughout a company, Black 
Belts face increasingly difficult 
problems which require advanced 
approaches and tools. Delighting 
the customer is what it’s all about, 
and that comes from consistent 
end-to-end process performance. 
Understanding complex 
processes, and identifying the 
optimal way to serve customers 
and shareholders is where 
process simulation plays a key 
role.” 

–Kevin Weiss
President 
The Capability Group
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Key Concepts
Connections
Connections are the lines connecting the graphic shapes. They 
include:

Entity Arrivals
Define where, when and in what quantities entities enter the system to 
begin processing. Entity arrivals are defined by connecting an entity 
to the activity or storage where it begins processing. Multiple arrival 
connections can be created from an entity to one or more 
activities/storages.

Entity Routings
Define the processing flow for entities. An entity routing is defined by 
connecting an activity or storage to the next activity or storage in the 
processing sequence. An activity or storage may have multiple input 
routings and multiple output routings. Entities do not move to the next 
activity or storage until there is available capacity and the condition or 
rule for routing the entity has been satisfied.

Resource Assignments
Define the use of resources in performing activities or moving 
entities. A resource assignment is defined by connecting a resource to 
either an activity or a routing depending on whether it is used for an 
activity or to make a move. Resources may be captured before any 
activity or routing and freed after any activity or routing. Multiple or 
alternative resources may be used for an activity or routing.
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Introduction To Process Modeling
Detailed Directions
This section provides the step-by-step instructions for how to build a 
process model. Specifically, it describes how to:

• Define the Process Flow

• Define Resource Assignments

• Enter Process Information

• Simulate your Process Model

• View the Output Reports

In this tutorial you will build a model of a familiar business process—
a help desk. It illustrates the power and simplicity of creating a 
working model using ProcessModel. The purpose of the model is to 
show how ideas for improvement can be tested using ProcessModel. 
This diagram shows the model we will create:

Incoming calls arrive at the help desk about every 5 minutes and a 
support representative evaluates the nature of each problem. The 
representative is able to resolve 75% of the calls immediately. 
However, 25% of the calls require that other support representatives 
do research and make a return call to the customer. The research itself 
combined with the return call requires 20 minutes.

“With process simulation as part of 
their training, Six Sigma Experts 
will be more successful in 
individual projects and companies 
will be more successful with their 
overall Six Sigma deployment.” 

–Rick Murrow
CEO of Air Academy 
Associates
6 \ ProcessModel Tutorial Copyright 2002



Detailed Directions
 Anchor Defining the Process Flow
Use this procedure to define all objects and connections in the process 
flow.
The first step to take in building a model is to define and connect the 
entity and each activity of the process. You will do this by placing 
shapes on the layout to represent the entity and each activity in the 
process sequence. Each shape is connected to the previous shape as it 
is placed on the layout. The diagram will be constructed from left to 
right.

1. Click once on the telephone symbol named Call in the 
Shape Palette to select it.

2. Move the cursor to the left side of the Layout and click once 
to place the shape.

In Brief: Defining the 
Process Flow

1. Click once on the telephone 
symbol named Call in the 
Shape Palette to select it.

2. Move the cursor to the left 
side of the Layout and click 
once to place the shape.

3. Click once on the rectangle 
named Process in the 
Shape Palette to select it.

4. Move your cursor to the 
Layout and position it over 
the Call shape. Click on it 
and drag to the right.

5. With the Process shape 
selected, type Take Call.

6. Click on the rectangle 
named Process in the 
Shape Palette again.

7. Move your cursor over the 
Take Call shape. Click on it 
and drag to the right.

8. Type Perform Research.

9. Repeat steps 6 and 7 to 
create Return Call 

10. Click on the Connector 
Line Tool in the Toolbox.

11. Place your cursor over the 
Take Call shape. Click on it 
and drag down.
ProcessModel, Inc. ProcessModel Tutorial/ 7



Introduction To Process Modeling
3. Click once on the rectangle named Process in the Shape 
Palette to select it. 

4. Move your cursor to the Layout and position it over the Call 
shape. Click on it and drag to the right. 

• Notice that your cursor changes shape as you move it over the 
Call shape.

• A new shape is placed on the Layout with a double arrow 
connection between it and Call. The double arrow indicates 
an Entity Arrival into the system. If you do not drag the 
shape, the connection will not be made and you will have to 
create it manually or delete the new shape and try again.

“Outdated systems crush ideas 
that could save a life. Redundant 
processes prevent us from 
adapting to evolving threats with 
the speed and agility that today’s 
world demands.” 

–Donald Rumsfeld
Secretary of Defense 
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Detailed Directions
5. With the rectangular shape Process selected, type Take 
Call.

• If the shape is not selected, simply click on it.

6. Click on the rectangle named Process in the Shape 
Palette again. 

7. Move your cursor over the Take Call shape. Click on it and 
drag to the right. 

8. Type Perform Research. 

9. Repeat steps 6 through 8 to create Return Call as shown 
below:

10. Create an exit routing for the 75% of the calls that the Level 
1 representative can handle immediately by clicking on the 
Connector Line Tool in the Toolbox.

11. Place your cursor over the Take Call shape. Click on it and 
drag down.
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Introduction To Process Modeling
Defining Resource Assignments
For this model, you need to define two customer support 
representatives, one to answer calls and one to do research and return 
calls. To define these resources, follow these steps:

1. Click on the shape of a person wearing a headset named 
Operator in the Shape Pallete.

2. Move your cursor to the Layout above the Take Call 
activity and click to place the shape, then type Support 1.

3. Repeat steps 1 and 2, placing the second Operator shape 
above the Perform Research activity and naming it 
Support 2.

In Brief: Defining Resource 
Assignments

1. Click on the shape of a 
person wearing a headset 
named Operator in the 
Shape Palette.

2. Move your cursor to the 
Layout above the Take Call 
activity and click to place the 
shape, then type Support 1.

3. Repeat steps 1 and 2, 
placing the second 
Operator shape above the 
Perform Research activity 
and naming it Support 2.

4. To connect the resources to 
their activities, click on the 
Connector Line Tool in the 
Toolbox.

5. Place your cursor over the 
Support 1 resource, click 
once and drag a connection 
down to the Take Call 
activity, then repeat steps 4 
and 5 to connect Support 2 
to Perform Research.

6. Repeat steps 4 and 5 to 
draw a connection from 
Support 2 to Return call.
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Detailed Directions
4. To connect the resources to their activities, click on the 
Connector Line Tool in the Toolbox.

5. Place your cursor over the Support 1 resource, click once 
and drag a connection down to the Take Call activity, then 
repeat steps 4 and 5 to connect Support 2 to Perform 
Research.

• Notice the green dots around the perimeter of the activity 
boxes when you drag a connection over them.

• Also notice the dashed lines with circles on each end between 
the resources and activities, indicating they are resource 
connections.

6. Support 2 also returns calls and has to be connected to 
that activity. Repeat steps 4 and 5 to draw a connection 
from Support 2 to Return call.
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Introduction To Process Modeling
Entering Process Information
You are now ready to complete the process information for the model. 
By double clicking on an entity, activity, resource, or connection, you 
open the Properties Dialog, which reflects the process information for 
that shape.
In this section, we will define the frequency of arrivals, enter activity 
times for the Take Call and Perform Research activities and define 
the percentage of calls that go to Perform Research and that exit the 
system. Finally, we will add cost information for the resources.

1. To select any object or connection, click on the Selector 
Tool, the arrow at the top of the Toolbox, then click on the 
object.

2. Double click on the Entity Arrival connection between Call 
and Take Call to open the Properties Dialog. Click on the 
drop down menu arrow next to the Type field and select 
Periodic. Type 5 into the field labeled Repeat every (i.e., 
repeat this arrival every 5 minutes).

In Brief: Entering Process 
Information

1. Click on the Selector Tool, 
the arrow at the top of the 
Toolbox.

2. Double click on the Entity 
Arrival connection between 
Call and Take Call to open 
the Properties Dialog. Click 
on the drop down menu 
arrow next to the Type field 
and select Periodic. Type 5 
into the field labeled Repeat 
every. 

3. Double click on the Take 
Call activity. Type 2 into the 
field labeled Time.

4. Double click on the 
connection between Take 
Call and Perform 
Research. Change the 
Percent field to 25.

5. In the New Name field, type 
in HardCall. 

6. Click on the Perform 
Research activity. In the 
Properties Dialog, enter 20 
in the Time field.

7. Click on Return Call and 
enter 3 in the Time field.

8. Select the Support 2 
resource and click on the 
Cost tab. In the Hourly 
Cost field, enter 20, for $20 
an hour.

9. Select Support 1. Enter 12 
in the Hourly Cost field.
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Detailed Directions
3. To make the duration of the Take Call activity 2 minutes, 
double click on the Take Call activity. Type 2 into the field 
labeled Time. 

4. To define the percentage of the calls that go to Perform 
Research, which is 25%, double click on the connection 
between Take Call and Perform Research. In the 
Properties Dialog, change the Percent field to 25.

• The percent field was automatically set previously to 50 
(percent) because two branches were created earlier, 
balancing the percentages. After changing this routing to 
25%, the other routing exiting down out of Take Call is 
automatically updated to 75% since there are only two 
percentage routings from this activity.

• While you are in this Percentage Routing Properties Dialog, 
you can separate the statistics that are displayed in the output 
report for the calls requiring research from the normal calls. 
This means that all of the easy call statistics (the ones that can 
be dealt with in two minutes) won’t be lumped together with 
hard calls. You will be able to see what is happening to 
customers requiring advanced help.
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Introduction To Process Modeling
5. In the New Name field, type in HardCall. 

• Just by typing in a new name the statistics will automatically 
be separated for any entity that follows this path.

6. The Perform Research activity takes 20 minutes. To enter 
this time, click on the Perform Research activity. In the 
Properties Dialog, enter 20 in the Time field.

• This would be a good time to further explain the Activity 
Dialog general tab. In this dialog there is an Input Queue, a 
Capacity and an Output Queue. You can think of these as a 
desk containing an inbox, a work area and an outbox. The 
default setting is to provide a large inbox, a work area for 1 
entity and no outbox.

“ProcessModel is one of the main 
tools in our toolkit. We train every 
Black Belt to use it. Recently, 
process simulation was critical in 
streamlining our sales admin 
process… That project alone 
saved between three million and 
ten million dollars.”

Angel Rivera
Master Black Belt 
Cordis, Johnson & 
Johnson
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Detailed Directions
7. Since the Return Call activity takes 3 minutes, click on it 
and enter 3 in the Time field.

8. Select the Support 2 resource and click on the Cost tab. In 
the Hourly Cost field, enter 20, for $20 an hour.

9. Select Support 1. Notice that the Cost tab remains 
selected. Enter 12 in the Hourly Cost field.

• You have now completed all of the steps to construct a basic 
model.
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Introduction To Process Modeling
Simulating your Process Model
The model is now complete and you are ready to run the simulation. 
Simulating your diagram is easy. With a click of the mouse, 
ProcessModel transforms this flowchart into an animated process 
simulation.

1. Click on the Simulation pull down menu and select Save & 
Simulate.

2. You will be prompted to save your process model. Type in 
Help Desk as the name of your file and click on Save.

In Brief: Simulating your 
Process

1. Click on the Simulation pull 
down menu and select Save 
& Simulate.

2. Type in Help Desk as the 
name of your file and click 
on Save.
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The Simulation Window
The Simulation Window
After the file has been saved, the simulation will begin to run and the 
simulation window will appear. As you are watching the simulation, 
you may want to take note of the following items:

• Telephone calls moving through the flowchart provide visual 
feedback of calls flowing through the process.

• Resources have a status light associated with them indicating 
when they are in operation. The status light is green when the 
resource is being utilized and blue when it is idle.
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Introduction To Process Modeling
• Counters are located above and to the left of each activity. 
They represent the number of calls waiting to process.

• The speed of the simulation can be controlled by moving the 
Speed Control Bar left for slower, right for faster.

• An on-screen Scoreboard keeps track of system statistics 
such as Quantity Processed, Cycle Time, Value Added 
Time, and Cost Per Unit.

"I've long ago left management of 
the industrial engineering function 
in our company (Thiokol 
Propulsion), but I'm continually 
impressed with the capability and 
utility of your software product 
based both on the monthly stories 
published in your magazine and 
the applications for the modeling 
software at our company. Keep up 
the good work!"

–Jim Ekstrom
Thiokol 
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The Simulation Window
Viewing the Output Reports
The reports and graphs in the Output Module can provide you with the 
information you need to make better decisions that will result in 
achieving the goals of the company, organization, or group. You will 
be able to identify problems and opportunities that may not have been 
readily apparent at the outset. You could find potential processing 
bottlenecks, under-utilized resources, or unused capacity. 
There are two types of output reports. One is an Output Summary 
which gives basic management overview information. The other 
provides Output Detail in the form of graphs, charts, and other 
decision-making information for the model builder.

Viewing the Output Detail

1. Click on Yes in the Yes / No question box that pops up after the 
simulation run ends. 

• Clicking on Yes will open the Output Detail report as shown 
below.

In Brief: Viewing the 
Output Detail

1. Click on Yes in the Yes / No 
question box that pops up 
after the simulation run 
ends.

2. Scroll down towards the 
bottom of the report to view 
the Resource States By 
Percentage and Entity 
Summary sections.

3. Click on the button depicting 
a bar graph called View a 
State or Utilization 
Summary Graph. 

4. Select Resource States 
from the State and 
Utilization Graph window 
and click on OK.

5. Click anywhere on the bar 
next to Support 2 to view 
this information in a pie 
chart.

6. To exit after the output data 
has been reviewed and 
analyzed, click on the File 
menu and select Exit.
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Introduction To Process Modeling
2. Scroll down towards the bottom of the report to view the 
Resource States By Percentage and Entity Summary 
sections. 

• You can see that Support 1 was in use 40% of the time, and 
Support 2 is in use almost all the time. This imbalance may 
indicate a problem area in your process. You may want to add 
more resources, change the assignment of resources or be 
prepared to have customers wait for extended periods for 
support. With ProcessModel, you can experiment with many 
different options to find the optimal solution.

• Move your cursor along the buttons at the top of the screen. 
The name of each button appears in the lower left hand corner 
of the screen as you pass your cursor over it.

3. To view this information in a graph, click on the button 
depicting a bar graph called View a State or Utilization 
Summary Graph. It is the seventh button from the left.

• You will see the State and Utilization Graph window.
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The Simulation Window
4. Select Resource States from the State and Utilization 
Graph window and click on OK.

5. Click anywhere on the bar next to Support 2 to view this 
information in a pie chart.

“Process simulation should be a 
part of every Black Belts toolkit. 
Over time, Black Belts are forced 
to look beyond the low hanging 
fruit. And that typically means 
working with processes that are 
more complex and difficult to 
visualize. Tools like ProcessModel 
become invaluable.” 

–Steve Fleming, 
CEO of Sigmax 
Solutions
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Introduction To Process Modeling
6. To exit after the output data has been reviewed and 
analyzed, click on the File menu and select Exit.

Viewing the Output Summary

1. To view the Output Summary, click on View and select 
Output Summary.

• The Output Summary provides information that a business 
manager would require to make a decision on a process 
change.

In Brief: Viewing the 
Output Summary

1. To view the Output 
Summary, click on View 
and select Output 
Summary.

2. To see the total cost for 
running the process for the 
week, click on Total Cost.

3. To see the average cost of 
each entity type, click on 
Entity Cost.

4. To obtain cost breakdowns 
for the resources in the 
process, click on Resource 
Cost.

5. To obtain cycle time for 
each entity type that exits 
the model, click on Cycle 
Time.

6. To obtain the amount of 
cycle time that adds value to 
the entity, click on Value 
Added Time.
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The Simulation Window
2. To see the total cost for running the process, click on Total 
Cost.

• Total Cost represents the sum of all the cost to run the 
process plus the addition of all unused resource costs.

3. To see the average cost of each entity type, click on Entity 
Cost.

• Entity Cost provides you with a realistic picture of the cost to 
produce one entity. Unused resource costs are applied to each 
entity type so you get a realistic picture of all costs involved 
in producing an entity.

4. To obtain cost breakdowns for the resources in the process, 
click on Resource Cost.
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Introduction To Process Modeling
• Resource Cost provides a breakdown of the cost of the 
resource for time utilized and for the time that the resource 
was utilized. This table helps you to quantify the resource 
waste in your process.

5. To obtain cycle time for each entity type that exits the 
model, click on Cycle Time.

• Cycle Time is the length of time that an entity remains in the 
simulation model. Cycle Time is given as a average.

6. To obtain the amount of cycle time that adds value to the 
entity, click on Value Added Time.

• Value Added Time is broken into Value Added, Non Value 
Added, and Book Value Added. These breakdowns allow you 
to determine what part of your process provides the values 
and what part does not.

In recent years, forward-thinking 
companies like IBM, Texas 
Instruments, and Duke Power 
have begun to make the leap from 
process redesign to process 
management. These companies 
are emerging from all those 
changes as true process 
enterprises--businesses whose 
management structures are in 
harmony, rather than at war, with 
their core processes. And their 
organizations are becoming much 
more flexible, adaptive, and 
responsive as a result.

Michael Hammer
Harvard Business 
Review 
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“The strongest benefit I see 
from ProcessModel is actually 
seeing a simulated process. 
You can always give a paper 
presentation and tell people 
what changes they should 
make, but with ProcessModel, 
they can actually see how their 
flow can improve. I can show 
people areas their hurting in, 
where their bottlenecks are, 
and, basically where they can 
save money. The visualization 
aspect of ProcessModel helps 
out tremendously.”

–Todd Vernon
GE Capital Auto 
Financial Services
Chapter 2

Making Decisions

Using ProcessModel to Improve 
Processes
Now that you know a little about how to build a ProcessModel, this chapter 
will focus on how to use the software to make process improvement 
decisions. Like Chapter 1, it is designed as a hands-on exercise that can be 
followed using the software. To make this exercise more realistic, we will 
use a slightly more complex version of the Help Desk model you just 
created. Specifically, this chapter contains the step-by-step instructions to 
help you learn how to:

• Open the New File

• Run the Simulation

• Print and Analyze the Output Reports

• Change the Model

In addition, this chapter answers the following questions:

1. How does ProcessModel calculate cost?

2. What are the current output results of the Help Desk process?

3. What goals should be met by improving the process?

4. What changes can be made to the process?
 ProcessModel Tutorial/ 2-1



Making Decisions
Key Concepts
We will be using a simple model of a familiar business process to 
quickly demonstrate the power of simulation as a decision-making 
tool. The same techniques can also be applied to understand and 
improve extremely complex processes. You will be shown a 
ProcessModel of a hypothetical help desk that accurately reflects the 
process as it is currently performed.You will then have an opportunity 
to identify specific process improvement opportunities and test the 
results of any changes against pre-determined goals.

This section presents the concepts necessary to successfully complete 
this exercise. Specifically you need to understand:

ProcessModel Cost Calculations
The cost shown in the Output Detail report reflects Activity Based 
Costing. It calculates the cost for individual entities based on the cost 
of associated resources and the amount of time an entity is being 
processed by those resources. It does not calculate the cost of 
resources when they are not actively processing an entity. To view the 
total operating cost of the process, you need to view the Output 
Summary report. 

Current Results
• It currently costs $2,786.12 to run the process for one week.

• About 34 calls a week are lost because they are not answered 
within 5 minutes.

• Calls requiring research take an average of 5.6 hours to complete.

• The Support2 resource is busy 97% of the time, but Support1 only 
52% of the time.

"In every potential customer 
briefing we demonstrate the 
modeling and simulation 
capabilities of ProcessModel. 
Every customer has sat in awe of 
the simulation and have remarked 
that they were unaware of how 
easily and quickly models can be 
made."

–Chuck Aucoin
Senior Process 
Simulation Engineer,
Dynamics Research 
Corporation
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Key Concepts
Prioritized Goals
• Reduce the total cost of running the process for a week to less 

than $2,025.

• Answer every call within 5 minutes

• Resolve every customer issue within 1 hour and 15 minutes.

• If possible, balance resource utilization so that no one resource is 
overburdened.

Changes to Make
You are free to make any changes to the model that you think will 
help reach the specified goals. However, this chapter contains step by 
step instructions for the following changes you may want to consider:

• Eliminating any non-value-added activities

• Investing in a new database that will reduce the average research 
time

• Upgrading the web site and phone system to answer more 
questions and re-direct callers, thereby reducing call volume

• Cross-training resources

• Hiring an additional resource
ProcessModel, Inc. ProcessModel Tutorial/ 2-3



Making Decisions
Detailed Directions
This section provides the step-by-step instructions for completing the 
exercise that will illustrate how to use ProcessModel to make 
decisions. Specifically, it describes how to:

• Open the New File

• Run the Simulation

• Print and Analyze the Output Report

• Change the Model

Whenever you make changes to a model for the purpose of comparing 
the output results and making process improvement decisions, you 
should only make one change at a time. You should save the model 
under a new name after each change so you can run a separate 
simulation to isolate the results of each change. You can then save 
models that test combinations of changes until your process 
improvement goals are accomplished.

“I have used ProcessModel to 
support the development of New 
Product Introduction in a number 
of countries. It has proved 
immensely valuable in 
understanding process capability. 
I see ProcessModel as an 
invaluable tool.” 

–David Jeffries 
GE Global Consumer 
Finance
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Detailed Directions
Opening the New File
1. Click on the File pull-down menu in the upper left hand 

corner of the screen and select Open.

2. Select Tutorial and click on Open.

• If the Demos folder does not open automatically, you may 
need to navigate to find it. Typically, ProcessModel will 
install the following sequence of directories:

• C:Program Files\ProcessModel4\Models\Demos\Tutorial

In Brief: Opening the New 
File

1. Click on the File pull-down 
menu in the upper left hand 
corner of the screen and 
select Open.

2. Select Tutorial and click on 
Open.

3. Click on the appropriate 
shapes to review the 
changes we made to the 
model you created in 
Chapter 1. More detailed 
directions on how to make 
some of these changes can 
be found later in this section.

NOTE:
If you received this tutorial via 
e-mail, the steps for Opening 
the New File will be slightly 
different. You should complete 
Step 1, but in Step 2 you will 
have to navigate to wherever 
you saved the .igx, .pmd, and .sft 
files that were attached to the 
e-mail.
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Making Decisions
• When you open the Tutorial file, the following model will 
appear:

3. Click on the appropriate shapes to review the changes we 
made to the model you created in Chapter 1. More detailed 
directions on how to make some of these changes can be 
found later in this section.
• We have added an activity called Supervisor Review and a 

Supervisor Resource to perform this task.
• We have added a Renege routing out of the Take Call 

activity where calls will exit the model if they have waited 5 
minutes without being processed.

• We changed the Entity Arrival rate to a Monday through 
Friday daily pattern with calls arriving every morning and 
afternoon in a normally distributed pattern with a larger 
number of calls on Monday to reflect customers who couldn’t 
call over the weekend.

• We changed the processing times for each activity to reflect a 
triangular distribution.

• We put all of the resources on a Monday through Friday Shift 
from 8:00 am to 5:00 pm.

• We set the simulation run time to stop at 6:00 pm on Friday.

“Continual pressure to accomplish 
more results with the same, or 
even reduced, resources has led 
to an assessment and analysis of 
where resources are expended.

Sarasota County Government has 
embraced ProcessModel as an aid 
in our efforts to this end. We have 
found this software useful not only 
in quantifying the steps of a 
process, but also in clarifying and 
communicating those steps.”

–Lora Hegener,
IT Project Manager
Sarasota County 
Government
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Running the Simulation
1. Click on the Simulation pull-down menu and select Save & 

Simulate.

2. Click on Yes in the Yes / No question box that pops up after the 
simulation run ends. 

• Clicking on Yes will open the Output Detail report as shown 
below.

In Brief: Running the 
Simulation

1. Click on the Simulation 
pull-down menu and select 
Save & Simulate.

2. Click on Yes in the Yes / No 
question box that pops up 
after the simulation run 
ends.
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Printing and Viewing the Output Report
1. Click on the File pull-down menu from the Output Report 

Screen and select Print.

2. Click on OK in the Print Window.

3. Find the Resources section of the report and make a note 
of the % Utilization.

In Brief: Printing and 
Viewing the Output Report

1. Click on the File pull-down 
menu from the Output 
Report Screen and select 
Print.

2. Click on OK in the Print 
Window.

3. Find the Resources section 
of the report and make a 
note of the % Utilization.

4. Find the Entity Summary 
section and make a note of 
the Qty Processed for 
Abandoned, the Average 
Cycle Time, and the 
Average Cost.

5. Close the Output Report by 
clicking on the X in the 
upper right hand corner of 
the screen.

6. Click on the View pull-down 
menu and select Output 
Summary.

7. Click on Total Cost to view 
the total operating cost of 
running the process for one 
week.
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Detailed Directions
4. Find the Entity Summary section and make a note of the 
Qty Processed for Abandoned, the Average Cycle Time, 
and the Average Cost.

• The cost shown in the Output Detail report reflects Activity 
Based Costing. To view the total operating cost of the 
process, you need to view the Output Summary report as 
shown below.

5. Close the Output Report by clicking on the X in the upper 
right hand corner of the screen.

6. Click on the View pull-down menu and select Output 
Summary.

“I have had some great 
experiences with Process Model. 
Process Model really helps to 
drive discipline in the process 
mapping of our procedures. It has 
been a real eye-opener and helps 
to illustrate bottlenecks. 
ProcessModel certainly should be 
part of the Six Sigma toolbelt.” 

–Todd Brognan 
GE Energy Services
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7. Click on Total Cost to view the total operating cost of 
running the process for one week.
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Detailed Directions
Changing Your Model
You are free to make any changes to the model that you think will 
help reach the specified goals. However, you may want to consider 
beginning with the following changes:

Eliminating the Non-Value Added Steps
Often times processes evolve over time, especially in businesses that 
are experiencing rapid growth. Frequently this evolution results in 
adding process steps that lose their value as things continue to change. 
These non-value-added steps are typically easy to identify once an 
organization focuses on finding them. If your use of ProcessModel 
helps you identify such steps, removing them from the model is easy.

1. While holding down the Shift key, click once each on the 
Supervisor resource and the Supervisor Review activity 
to select them.

2. Press the Delete key and the Delete/Cut Verification box 
will appear:

In Brief: Eliminating the 
Non-Value Added Steps

1. While holding down the Shift 
key, click once each on the 
Supervisor resource and the 
Supervisor Review activity 
to select them.

2. Press the Delete key and 
the Delete/Cut Verification 
box will appear:

3. Click on the Yes button, and 
the Supervisor and 
Supervisor Review shapes 
will be deleted.

4. Click on the File menu and 
select Save As.

5. Name the file No Supervisor 
and click on Save.
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3. Click on the Yes button, and the Supervisor and 
Supervisor Review shapes will be deleted.

4. Click on the File menu and select Save As.

5. Name the file No Supervisor and click on Save.

“Within ProcessModel, there is 
great application to six sigma. GE 
thrives on sigma levels, and 
ProcessModel shows us how we 
can reach our targeted goal. 
ProcessModel is definitely a 
value-adding tool.” 

–Todd Vernon
Black Belt, 
GE Capital Auto 
Financial Services
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Detailed Directions
Reducing Activity Times
Sometimes the actual time to perform a given process step can be 
reduced. This is often accomplished by the use of technology. Some 
examples include networks, databases, or peripherals like Palm Pilots 
and barcode scanners.

1. Click on the Perform Research activity to open the 
Properties Dialog.

2. Click and drag across the Time field in the Perform 
Research Properties Dialog to highlight it.

3. Type T(10,15,20) with no spaces. This is a triangular 
distribution which means that it takes at least 10, usually 15, 
and sometimes 20 minutes to Perform Research.

4. Click on the File menu and select Save As.

5. Name the file Faster Research and click on Save.

In Brief: Reducing Activity 
TImes

1. Click on the Perform 
Research activity to open 
the Properties Dialog.

2. Click and drag across the 
Time field in the Perform 
Research Properties Dialog 
to highlight it.

3. Type T(10,15,20) with no 
spaces. This is a triangular 
distribution which means 
that it takes at least 10, 
usually 15, and sometimes 
20 minutes to Perform 
Research.

4. Click on the File menu and 
select Save As.

5. Name the file Faster 
Research and click on Save.
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Adding Resources
Hiring new team members is expensive. ProcessModel can help you 
assess the impact of potential new team members before you go 
through the costly hiring and training process.

1. Click on the Support1 resource. This will open the 
Properties Dialog box.

2. Enter the number 2 in the Quantity field, as shown.

3. Click on the Take Call activity. This will open the 
Properties Dialog box.

4. Enter the number 2 in the Capacity field, as shown.

5. Click on the File menu and select Save As.

6. Name the file Additional Resource and click on Save.

In Brief: Adding Resources

1. Click on the Support1 
resource. This will open the 
Properties Dialog box.

2. Enter the number 2 in the 
Quantity field, as shown.

3. Click on the Take Call 
activity. This will open the 
Properties Dialog box.

4. Enter the number 2 in the 
Capacity field, as shown.

5. Click on the File menu and 
select Save As.

6. Name the file Additional 
Resource and click on Save.
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Cross-Training Personnel
Making better use of existing staff is usually a better alternative than 
additional hiring. Cross-training is a way of providing current 
employees with the skills to perform new responsibilities.   
ProcessModel can easily help you evaluate the effect of having 
existing resources help out in other areas.

1. Click on the Connector Line Tool near the upper left 
corner.

2. Click once on Support1, then move your cursor to the 
connection between Support2 and Perform Research. 
When you see a small flashing circle on the end of the 
cursor, click again to place the connection.

• The Properties Dialog will show that this is an Alternate 
Routing.

In Brief: Cross-Training 
Personnel

1. Click on the Connector Line 
Tool near the upper left 
corner.

2. Click on the Connector Line 
Tool near the upper left 
corner.

3. Since you now have 2 
additional resources 
available, click on Perform 
Research, and increase the 
capacity to 3.

4. Click on the File menu and 
select Save As

5. Name the file Cross Train 
and click on Save.
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3. Since you now have 2 additional resources available, click 
on Perform Research, and increase the capacity to 3.

4. Click on the File menu and select Save As

5. Name the file Cross Train and click on Save.

“Using the power of simulation to 
model processes, Newport News 
Shipbuilding is able to illustrate 
high cost process flows and 
recommend cost saving solutions. 
ProcessModel helps us identify 
the redundancies in a process, the 
waste, and the non-value added 
activities.”

–Mark Ristow 
Production Engineer 
Newport News 
Shipbuilding
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Reducing Entity Arrivals

Companies can sometimes decrease the amount of work coming into 
the system. Examples include the call center which implements a new 
phone menu system that answers some of the most common 
questions, or the company that adds more details to their on-line FAQ 
list. Outsourcing of a particular type of work is another example of 
how this may be accomplished.

1. Click on the Entity Arrival Routing (double-headed arrow) 
between Call and Take Call to open the Properties Dialog.

2. Click on Define Pattern to open the Daily Pattern box.

In Brief: Reducing Entity 
Arrivals

1. Click on the Entity Arrival 
Routing (double-headed 
arrow) between Call and 
Take Call to open the 
Properties Dialog.

2. Click on Define Pattern to 
open the Daily Pattern box.

3. Click on the Quantity field 
and change the 65 to 60, 
then click on the 12:00pm - 
5:00pm, N(55,5) line in the 
Start-End, Quantity field.

4. Click on the Quantity field 
and change the 55 to 50, 
then click on Tuesday in the 
Day field.

5. Click on the Quantity field 
and change the 48 to 45, 
then click on the 8:00am - 
12:00pm, N(48,2) line in the 
Start-End, Quantity field.

6. Click on the Quantity field 
and change the 48 to 45, 
then click on the Copy Day 
button.

7. Click on Wednesday in the 
Day field, then click on the 
Paste Tuesday button.

8. Repeat Step 7 for Thursday 
and Friday, then click on the 
Close button.

9. Click on the File menu and 
select Save As..

10. Name the file Reduced 
Arrivals and click on Save..
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3. Click on the Quantity field and change the 65 to 60, then 
click on the 12:00pm - 5:00pm, N(55,5) line in the 
Start-End, Quantity field.

4. Click on the Quantity field and change the 55 to 50, then 
click on Tuesday in the Day field.

5. Click on the Quantity field and change the 48 to 45, then 
click on the 8:00am - 12:00pm, N(48,2) line in the 
Start-End, Quantity field.

“ProcessModel is well suited for 
analyzing, understanding and 
improving various logistical and 
business processes. It was selected 
because it is user friendly, flexible, 
cost effective, and it provided the 
detailed features to satisfy the 
project requirements.”

Scott Sutherland
PricewaterhouseCoopers, 
LLP
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Detailed Directions
6. Click on the Quantity field and change the 48 to 45, then 
click on the Copy Day button.

7. Click on Wednesday in the Day field, then click on the 
Paste Tuesday button.

8. Repeat Step 7 for Thursday and Friday, then click on the 
Close button.

9. Click on the File menu and select Save As.

10. Name the file Reduced Arrivals and click on Save.
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Next Steps
We hope this tutorial has given you a feel for how ProcessModel 
software can be used to improve business processes. Visit our website 
to discover how other companies in your industry have been 
successful, or call us at the number below. The ProcessModel team 
will be happy to help you determine what an implementation might 
look like at your organization.

ProcessModel, Inc.
132 W. Center St. Ste 301
Provo, Utah 84601
801-356-7165 phone
801-356-7175 fax
www.processmodel.com 
info@processmodel.com
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